RuckusVLANでWifi接続-GWはUntangle

VLANを切って接続

Ruckusって面白いですね。無線LANでVLANを切ってSSIDごとにそのVLANに接続させる事が可能です。

WireLessLANグループ作成

WGでは、SSIDを作成します。認証方式などもここで作成できます。

アクセスポイントグループ作成

物理的に取り付けたアクセスポイントをグループ化します。

また、アクセスポイントに上記で作成したWireLessLanグループを割り当てます。WLANグループと表記されています。

UntangleでDHCP確認

UntangleでDHCPがちゃんと吐き出されている事を確認

指定のIPアドレスが取得できているか確認

WireLessLanグループでVLAN変更

所属しているVLANの値を変更する

以下、完全に覚書です。

負荷テスト

Catalyst3650(L3) QoS設定要所

interface Vlan200
 description ## intercom ##
 ip address 172.20.1.254 255.255.255.0
 ip access-group INTERCOM-FILTER in
 service-policy input VoIP-Policy

Vlan200に割り当てた、ip adreess範囲について、受信した全てのフレームをDSCP46にセットするというポリシー

デフォルトで音声は帯域保障され、動画、制御系等は異なる出力キューに割り当てられるようになっているため、CoSやDSCP値が設定されたフレームを受信した場合、又は受信したインターフェースでマーキングするとそれぞれ異なるキューに割り当てられるようになり、推奨された優先度に従って送信されるようになる

L3配下の有線LANパソコン6台

R510配下の無線LANパソコン6台

パターン1

L3配下のパソコンをサーバ

R510配下のパソコンをクライアントとして、netmiアプリでマックスまで負荷をかける。QoSがかかったインカム帯域は影響なく通信できるか?

インカム音声通話は特に問題なく行う事ができた

パターン2

L3配下のパソコンをクライアント

R510配下のパソコンをサーバとして、netmiアプリでマックスまで負荷をかける。QoSがかかったインカム帯域は影響なく通信できるか?

インカム音声通話は特に問題なく行う事ができた

パターン3

R510配下のパソコン同士で、netmiアプリでマックスまで負荷をかける。QoSがかかったインカム帯域は影響なく通信できるか?

インカム音声通話は特にい問題なく行う事ができた

トンネルモード

ZD1200に、トンネルモードを設定できる。

トンネルモードを設定すると、無線クライアントと、ZD1200が直接通信するイメージで、APをローミングしても遅延なく通信する事ができる。

インカム設定でこちらを行った。

※ローミング時遅延が起きる理由は、macアドレスを間に挟むL2SWが記憶しており、ZD1200側から出たパケットが落ちてしまうため。トンネルすると、それぞれのAPの配下のクライアントをL2レベルでZD1200が管理する。

トンネルモードの設定

Wireless LANsの設定で、SSIDごとに設定できる。

ACLの書き方

ip access-list extended IP01-FILTER
 deny   ip any 172.15.0.0 0.0.255.255
 deny   ip any 172.35.1.0 0.0.0.255
 deny   ip any 172.40.1.0 0.0.0.255
 deny   ip any 172.45.0.0 0.0.255.255
 deny   ip any 172.50.0.0 0.0.255.255
 deny   ip any 172.55.99.0 0.0.0.255
 permit ip any any

このIPアドレスの書き方が独特で何なんだろうと思う。

172.15.0.0 0.0.255.255 ⇒ 172.15.0.0/16という事らしい。なんか紛らわしい。せめて、

172.15.0.0 mask 255.255.0.0というような書き方をしてくれると分かるのに。

ACLの割り当て方

interface Vlan5
 description ## lan_IP01 ##
 ip address 192.168.11.254 255.255.255.0
 ip helper-address 192.168.11.5
 ip access-group IP01-FILTER in

IP01-FILTERを割り当てるのはVLANを作って割り当てる。

ポートへの割り当て

interface GigabitEthernet1/0/1
 description ## Honden ##
 switchport trunk allowed vlan 5,11,102
switchport mode trunk
 storm-control broadcast level 50.00
 storm-control action shutdown
 spanning-tree portfast trunk
 service-policy input cos-change-policy
 service-policy output cos-output1G-policy

swichport trunkが taggedの意味。vlan 5,11,102番が割り当てられる。このvlan番号は、メーカーが違っても準拠してれば同じ番号でタグVLANが通信可能になる。

関連コンテンツ