CiscoとアライドをVLAN連携してさらにBuffaloの無線APにVLANごとのSSIDを設定する

Ciscoとアライドの L3,L2スイッチを連携してVLAN設定する事は出来ました。

今度はそれに加えて、Buffaloの無線LANを設定し、Buffaloの無線LANに任意のVLANにSSIDを割り当てます。

HUB3台を利用して、VLANを構築し、指定のポートでそのVLANの口を作成します。

さらにCiscoのCatalyst 3560 PoE24スイッチを利用して、Buffaloの無線LANアクセスポイントをぶら下げ、任意のVLAN IDとSSIDを紐づけ、そのSSIDに接続した人は、そのVLANネットワークに入れるという設定を行います。

Cisco WS-C2960L-8PS-JP

アライド GS924M V2

Cisco Catalyst 3560 PoE24

アライドテレシス CentreCOM VT-Kit2 plus RS232Cケーブル/コンソールケーブルセット 0212R

シスコはIPを用いてtelnetし、アライドのHUB類は、コンソールケーブルを利用して接続しました。

さらに Catalyst 3560は、このアライドのコンソールケーブルが利用可能です。

Linuxでこのシリアルケーブルを利用する場合はこちらをご参考にしてください。

パスワード入力後 en コマンドにて特権モードに入りコンフィグを書き換える。

現在の設定確認

#show running-config

コンフィグ編集モードへ

#configure terminal

現状のコンフィグ確認

show config dynamic

コンフィグファイルとして保存されているのは?

show file

コンフィグリセット

set config=none
RESTART REBOOT

※この方法ではパスワードは初期化されません

起動時読み込むファイルの設定

SET CONFIG=settei.cfg

VLAN設定

CREATE VLAN=wifi_gyomu VID=230 
CREATE VLAN=wifi_guest VID=300

ADD VLAN=wifi_gyomu PORT=23-24 FRAME=TAGGED
ADD VLAN=wifi_guest PORT=23-24 FRAME=TAGGED

add vlan="wifi_gyomu" port=1
add vlan="wifi_guest" port=2

port1 が業務Wifiネットワークに接続できる事を確認

port2 がゲストWifiネットワークに接続できる事を確認

create config=testvlan.cfg
set config=testvlan.cfg

現状のコンフィグ確認

show config dynamic

コンフィグファイルとして保存されているのは?

show runnning-config

特権モードから編集モードに入る

en
configure terminal

VLANの設定

vlan 230,300,1000
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 description -- To gyomu-wifi
 switchport access vlan 230
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
 description -- To guest-wifi
 switchport access vlan 300
 switchport mode access
 spanning-tree portfast

interface FastEthernet0/23
 switchport trunk allowed vlan 230,300,1000
 srr-queue bandwidth share 255 50 25 25
 priority-queue out 
 mls qos trust dscp
!         
interface FastEthernet0/24
 switchport trunk allowed vlan 230,300,1000
 srr-queue bandwidth share 255 50 25 25
 priority-queue out 
 mls qos trust dscp

アライド GS924M V2とCatalyst3560の24ポート接続

port1 で業務wifiネットワークに接続できる事を確認

port2でゲストwifiネットワークに接続できる事を確認

設定を保存するのは、

write

スイッチ同士をループさせてみると

00:36:20: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:36:21: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/1 VLAN230.
00:36:21: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/1 on VLAN0230. Inconsistent port type.
00:36:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

パソコンとつなげると

00:42:01: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:42:02: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Trunkポートに設定したはずのポートから、うまくAPに反映されない事が分かり何でかとっても悩みました。

アライドのL2スイッチや、新しいCiscoのL2スイッチとはTagged,Trunkの設定がうまくいき通信ができているのに、APだけはできない。これはAPの方の相性なのかと諦めかけていたその時にCatalystでtrunkモードを使うのには、設定が必要な事が分かりました。

曲者はこいつです。

 switchport trunk encapsulation dot1q

インターフェイスを使用して、トランク ポートのカプセル化タイプを選択します。

なんのこっちゃ意味は分からんのですが、このコマンドを入れておかないと、

switchport mode trunk

が通りませんでした。dot1qを入れていない時に表示されるエラーメッセージは

Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

なので、最初はAutoモードになっていて、インターフェースの先が他のSWのtrunkなのかAccessなのかによって勝手に切り替わるのか?と思いますが、症状からいくとアライド系のL2SWや、Ciscoの新しいL2SWとはAutoでうまくいくけど、その他BuffaloのAPとかと通信するにはちゃんと、switchport mode trunkが入っていないとダメなんかなぁと思う所です。

結論から、

Catalyst 3560 ではうまくtagvlanでの通信はできませんでした。

WS-C2960L-8PS-JP ではうまくtagvlanを解釈できるようで、SSIDをそれぞれのVLANに所属させ、GyomuWifi,GuestWifiを利用する事が出来ました。

アライドと、CiscoのSW同士はうまくtagを解釈してVLAN構成できましたが、CiscoのPoEスイッチ配下にWAPS-APG600Hを置き、tagged設定を試みたものの、tagを解釈できない様子。SSIDごとのVLANに入るどころか、管理IDにも全くアクセスできない状況です。

ファームウェアも最新である事を確認しましたが、結局お手上げ状態で、Buffaloの無線APはちょっと特殊なのか?と思ってしまいました。

業務Wifi,ゲストWifiどちらとも無線LAN SSIDに接続はできるものの、そのVLAN IDネットワークに入る事は出来ませんでした。

今回の結論として、Buffaloのサイト上設定事例集を見たところ、BuffaloのL3 SWを利用すれば使えるのかな?という所と、web上にCiscoルータと接続してVLANしてますという情報が皆無で、これ以上の追及は難しいと判断しました。

諦めの悪い私は、なんとかこのCatalyst3560とでTagVLAN接続できる安価なAPはないものかと試しておりましたら、

型番

アライドテレシス 1952R AT-MWS1750AP

と、Catalyst3560との組み合わせでうまくTagを解釈してくれるようになりました。

もちろん、Catalyst側のTagポート設定に

 
switchport trunk encapsulation dot1q
switchport mode trunk

の設定が必要です。これを行っていないと、BuffaloのAPと同じようにうまくTagVLANは働きませんでした。

当然ですが、WS-C2960L-8PS-JP とも苦労なく接続可能です。最新の機器同士で設定行うのが労力が一番少なそうです。

まとめ

時間がない時にはお金をかけて、最新のもので、しかもメーカーを揃えた形で設定した方がいいよね。

関連コンテンツ