PRIMERGY TX1310M1 RAID1 2TBの制限あり 監視ツール設定とか

RAID1構成を構築してみる

オンボードRAIDを有効にしにして、RAID1構成にします。BIOSから設定します。

SATA ModeをRAID Modeへ

すると、RAIF BIOSが有効になる

ctrl + mキーでBIOS画面に推移

2TBごえのHddはConfig画面にでてこなかったのだが、一度Biosにもどって、キャンセルしてもう一度RAID設定画面に入ったら、4TBのディスクも認識するようになった。

インストールには、付属のSoftware ServerView を利用する。

起動すると

 と、警告が出るのでUSBメモリを指しておく

SeverViewのRAID管理機能

CDブートで利用可能

 インストールDeproyを始める

一応RAIDインストール完了したっぽい。

だけど c ドライブ以外は見れない レイドマネージャーで レディーの状態ではいけないような気がする

オンラインに変えてみる

 それぞれのドライブをオンラインにし、コンフィグする。コツとしては、2つ同時にコンフィグするのではなく一つ一つコンフィグしてRAID0で組むこと

すると、このような構成で構築できる

しかし、フォーマットすると残念だけどOS領域は2TBまでしか認識できない。2TBの壁にぶち当たる。OS領域以外は、GPTディスクに変換することで全ての領域が利用可能になるがOSが入っている領域は、GPTに変換できません。

RAIDを構築したら管理ツールは非常に大切です。

オーノー。元々設定されていたRAID MANAGERは正常に動作しませんでした。バジョンも古いし、I.E.もセキュリティ更新などで変わっていっているし、で、新しくダウンロード設定し直さなければならないようです。

最新バージョンをダウンロードしインストールします。サーバー関連のアプリケーションはここからダウンロード可能です。

SVSのLight運用

私の環境では、1台を簡単に管理したいだけなので、簡単運用を行います。このために必要なのが、ServerView Agentsと、RAID MANAGERです。

ServerView Agentsは、TX1310M1を選んで単体でダウンロード可能ですが、ServerView RAID ManagerはTX1310M1を選択後単体でダウンロードはできない状態なので、他から探してきます。

ServerView Agents for Windows

ServerView RAID Manager V6.4.14

ServerView RAID Managerはこんな感じです。RAIDの状態を監視でき、0の位置のHDDをで障害を起こし、LogicalDrive_0が縮退運転しています。0の位置のHDDはわざと抜いた状態です。

※動かすコツ ホスト名:3173の形ではなかなかアドオンが実行できませんでした。

https://localhost:3173 だと無事動きました。

抜いたRAID1構成をしていたHDDを再度装着します。するとリビルドが始まります。このサーバはホットプラグには対応していないので、もちろん一度電源を落としてから作業します。

縮退運転中にビープ音を鳴らします。ServerView System Monitorの設定でサウンドをONにしておくと、ビープ音が断続的に鳴って異常を知らせてくれます。

ステータスでは、外部記憶装置に異常をきたしている事が分かります。

ミュートスピーカボタンを押すとビープ音はならなくなります。

リビュルドが終わって正常運転に戻ると、自動的にミュートスピーカボタンはなくなります。

注意

ServerView System Monitor起動時に、パスワードを要求されます。うむ、まいったって感じで、Administratorのユーザ名パスワードでログオンできません。そこで、

ServerView SNMP agents設定を起動し、パスワードによる保護を有効にするのチェックを外したら、何も聞かれなくなりました。ここの設定によると、ユーザグループの権限を付けたユーザじゃなきゃダメそうですね。

RAIDを組んでいる時のWindowsバックアップ復元

RAIDを組んでいる状態でのWindowsImageの復元は厄介です。Windowsインストーラに標準でRAIDコントローラドライバが組み込まれていればいいのですが、このマシンLSI MegaRAIDドライバは組み込まれておらず、無数にあるMegaRAIDドライバから割り当てる事もできず、復元する際にRAIDでない状態で復元されてしまうため、結局復元しても起動できずでした。

一応試行錯誤はしてみました。

新たにWindowsを入れ直し、ドライバを組んでその状態で復元したらどうか

これはRAIDが組まれている状態です

うん、ここまでいけばと期待したのですが、

Systemが入って起動している状態ではだめで、やっぱり外付けのDVDメディアからの起動を促されてしまいました。

残念。結局一から再セットアップです。

RAIDが利用できなくなった

何気にWindowsUpdateしたら、起動しなくなりました。( ノД`)シクシク…

サーバーなのにそんなのありでしょうか?WindowsUpdat後起動しなくなったんです。

Update後再起動すると、なぜかBIOS画面でWARNING!表示がされます。なぜBIOSまで影響するのか意味は分かりませんでした。

あ”-ブルースクリーンです。なぜなんだあ。

仕方ないのでRAIDを解除しAHCI Modeで再インストールしたら、無事起動しました。サーバなのにこんなのでいいんでしょうか?LSI MegaRAIDは使っちゃダメなのかなぁ。

インストール後プロダクトキーが入らない

インストール後、プロダクトキーを入力してWindows2012 R2のライセンス認証をすると、「このキーは使用できません。キーを確認してやり直すか、別のキーを試してください。」と表示されて困りました。

ライセンス認証は、

slmgr -ipk プロダクトキー

とする事で無事に認証できました。

監視カメラが起動しない

WindowsUpdateの弊害なのか、今まで起動していたPanasonicネットワークカメラ専用録画ビューアソフト BB-HNP17が起動しなくなりました。

これは以前も経験していて、

Windows2012SRV R2をデフォルトでインストールしたら、デスクトップエクスペリエンスが有効になっていなかったらしく、WindowsMediaPlayerが有効になっていませんでした。これを有効にする事で動き始めました。

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)