CiscoとアライドテレシスのL3SWやL2SWを接続してVLANする話

アライドとシスコ。昔からアライドのHUBを導入しているうちの環境に最近シスコが登場してきました。これをうまく連携させてネットワークを組んでいきます。

私は業者さん任せはあまり好きでなく、自前でなんでも構築していくというのが今までのスタイル。最初に基礎的な設計は済ませていただいたので、後はこちらでネットワークを好きなようにカスタマイズしていきます。

そのために必要なのがシスコとアライドのVLAN連携です。

その試験を行います。

HUB3台を利用して、VLANを構築し、指定のポートでそのVLANの口を作成します。

Cisco WS-C2960L-8PS-JP

アライド GS924M V2

アライド 9606T

アライドテレシス CentreCOM VT-Kit2 plus RS232Cケーブル/コンソールケーブルセット 0212R

シスコはIPを用いてtelnetし、アライドのHUB類は、コンソールケーブルを利用して接続しました。

パスワード入力後 en コマンドにて特権モードに入りコンフィグを書き換える。

現在の設定確認

#show running-config

コンフィグ編集モードへ

#configure terminal

そしてコンフィグ設定。8番ポートにタグVLANを仕込みます。

interface GigabitEthernet0/8
 description -- VLAN TDST
 switchport trunk allowed vlan 230,300
 switchport mode trunk
 spanning-tree portfast edge trunk
#spanning-tree portfast edge trunk
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

PortFastは、単一ポートに接続されているポートでのみ有効にする必要があります。 ホスト、ハブ、コンセントレータ、スイッチ、ブリッジなどを接続する場合、 PortFastが有効になっていると、一時的なブリッジングループが発生する可能性があります。

PortFast は、スパニング ツリーがコンバージェンスするまでにインターフェイスが待機す
る時間を最短にするため、これはエンドステーションに接続されているインターフェイス
で使用される場合のみ有用です。他のスイッチに接続するインターフェイスで PortFast を
イネーブルにすると、スパニングツリーのループが生じることがあります。

つまり、HUBとHUBをつなげる時は、

spanning-tree portfast edge trunk

を入れてしまうとループしてしまう可能性があるという事。

ただ、PortFastが入っていないと、そのポートでスパニングツリー計算がなされ、ポートに刺してから1分ほどリンクが上がらないという事もあり非常に使いづらいです。

このサイトの説明が分かりやすいです。

PortFastとは,シスコのSTP (Spanning Tree Protocol)における拡張機能のことです。 PortFastが設定がされているポートは,接続された場合にすぐにリンクアップすることができます。

PortFastは,端末を接続するポートなど,ループが発生しないことがあらかじめわかっているポートを直ちに通信できる状態にしたい場合に適用します。

PortFast 機能を使用すると、アクセス ポートまたはトランク ポートとして設定されているインターフェイスが、リスニング ステートおよびラーニング ステートを経由せずに、ブロッキング ステートから直接フォワーディング ステートに移行します。

スパニングツリーは、レイヤー2におけるループを防止するための機能です。 ループを防止しながらネットワークを冗長化できます。

現状のコンフィグ確認

show config dynamic

コンフィグファイルとして保存されているのは?

show file

コンフィグリセット

set config=none
RESTART REBOOT

※この方法ではパスワードは初期化されません

起動時読み込むファイルの設定

SET CONFIG=settei.cfg

VLAN設定

CREATE VLAN=wifi_gyomu VID=230 
CREATE VLAN=wifi_guest VID=300

ADD VLAN=wifi_gyomu PORT=23-24 FRAME=TAGGED
ADD VLAN=wifi_guest PORT=23-24 FRAME=TAGGED

add vlan="wifi_gyomu" port=1
add vlan="wifi_guest" port=2

port1 が業務Wifiネットワークに接続できる事を確認

port2 がゲストWifiネットワークに接続できる事を確認

create config=testvlan.cfg
set config=testvlan.cfg

現状のコンフィグ確認

show config dynamic

コンフィグファイルとして保存されているのは?

show file

コンフィグリセット

set config=none
RESTART REBOOT

※この方法でパスワードも初期化される。GS924M V2と挙動が違うので注意が必要。

VLAN設定

CREATE VLAN=wifi_gyomu VID=230 
CREATE VLAN=wifi_guest VID=300

ADD VLAN=wifi_gyomu PORT=6 FRAME=TAGGED
ADD VLAN=wifi_guest PORT=6 FRAME=TAGGED

add vlan="wifi_gyomu" port=1
add vlan="wifi_guest" port=2

port1 にて業務wifiネットワークに接続できることを確認

port2にてゲストwifiに接続できることを確認

設定したコンフィグを保存し起動時読み込む

create config=testvlan.cfg
set config=testvlan.cfg

VLAN IDを決めてしまえばアライドもシスコも簡単にVLAN組めます。

アライドはtagged

シスコはtrunk

という事さえ分かれば、後はあまり悩む事はなさそうです。

おまけ

増設するアライドのL2 SWには、IPアドレスを振る事が可能です。IPアドレスがあれば、ネットワーク上から直接TELNETをかける事ができます。

IPアドレスを振っていないと、何かトラブルがあったら、まずは現場へ、設定変更が必要になったらまずは現場へという事になってしまいます。

IPアドレスを振っていれば、とりあえず状況を確認して何が起こっているかを把握してから現場へ行くような第1段階の切り分け作業が効率的に行えます。

管理VLANを500とする

Cisco WS-C2960L-8PS-JP

interface GigabitEthernet0/8
 description -- VLAN TDST
 switchport trunk allowed vlan 230,300,500
 switchport mode trunk
 spanning-tree portfast edge trunk

アライド GS924M V2

CREATE VLAN=wifi_gyomu VID=230 
CREATE VLAN=wifi_guest VID=300
create vlan="kanri" vid=500

ADD VLAN=wifi_gyomu PORT=23-24 FRAME=TAGGED
ADD VLAN=wifi_guest PORT=23-24 FRAME=TAGGED

add vlan="wifi_gyomu" port=1
add vlan="wifi_guest" port=2

add ip interface=kanri ipaddress=192.168.0.235 mask=255.255.255.0 gateway=192.168.0.254

※同じアライドのHUBでも年代によって、IPアドレスの書き方などちょっとした違いがあります。

アライド8424XL

CREATE VLAN=wifi_gyomu VID=230 
CREATE VLAN=wifi_guest VID=300
create vlan="kanri" vid=500

ADD VLAN=wifi_gyomu PORT=23-24 FRAME=TAGGED
ADD VLAN=wifi_guest PORT=23-24 FRAME=TAGGED

add vlan="wifi_gyomu" port=1
add vlan="wifi_guest" port=2

enable ip
add ip int=vlan500 ip=192.168.0.235
add ip rou=0.0.0.0 mask=0.0.0.0 int=vlan500 next=192.168.0.254 

GS924M V2 HTTPサーバ

GS924M V2をWeb GUIで管理するためにはコマンドからHTTP SERVERを有効にする必要があります。

ENABLE HTTP SERVER

サーバーにファイルをアップロードするときにローカルディレクトリのパスを含める

httpサーバを有効にして、ファームウェアを更新しておこうと思ったら、どのブラウザを利用しても、

「ファイル名が含まれていません」

となり、結局ファイルをアップロードできませんでした。

何らかの設定で

「サーバーにファイルをアップロードするときにローカルディレクトリのパスを含める」

を有効にしてあげればいいと思うのですが、中々時間がないのでファイルのアップロードはftpで、ファームウェアの読み込みは

GS924M V2ファームウェアの更新

ftpを有効にします。

enabe ftp server

Windowsのエクスプローラ(ファイルを開くやつ)

\\GS924MのIPアドレス

で、ファイルフォルダとして開く事が出来ます。これができれば、ドラッグアンドドロップで、ファイルをアップロードできます。

今回の霊は\\172.20.0.214です。

すると、WebGUIの法衣も新しいファームが見えるようになるので、新しいコンフィグを選択します。

これで設定し再起動すると、無事に新しいファームで起動してくることがコンソール画面で分かります。

Allied Telesis CentreCOM GS924M V2 Ethernet Switch
Ethernet Switch Software: Version 2.4.6
MAC Address: 00-1A-
Running 1min 58secs

Manager > 

アライド8424XLパスワード変更

パスワードの変更は

set user=manager password=パスワード文字列

Catalyst3560のホスト名とパスワード

ホスト名とパスワードをつける

hostname L2SW
enable password パスワード文字列

Catalyst3560 telnetできるようにする

line con 0
line vty 0 4
 password パスワード文字列
 login
line vty 5 15
 no login

関連コンテンツ